Upstream ACH provider outage

Incident Report for Teampay

Resolved

The outage from the upstream provider is resolved. We are still monitoring the situation.
Posted Nov 18, 2025 - 18:13 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 14:11 UTC

Investigating

An outage from an upstream provider may impact ACH payments. We are monitoring the situation.
Posted Nov 18, 2025 - 14:07 UTC
This incident affected: External (Dwolla).